Re: Name discussion for new primtive

From: Bernd Brassel <>
Date: Fri, 12 Nov 2004 10:19:31 +0100

I like to include "ensure" in the name as well. And I thought about what
Michael wrote earlier:

> I think
> that groundHnf sounds a bit too technical. When I teach functional
> (logic) programming, first I explain the constructs of the language
> without defining the concrete evaluation strategy.

and what Igor contributed:

> From my newbie point of view short names like "eval","rigid" or
> "ensure" or even "rigidSpine" looks bette than complicating
> "groundHnf".

Thus, we might need a word for "constructor-head-normal-form" which is
much less technical and well understandable for newbies. I think that a
nice term might be "pattern". So how about "ensurePattern"? Or is this
too long again?

In order to give a summary of where the discussion is now, I think the
following terms are those with current promoters:

a) ensure...
b) eval2...

full names
1) nonVar
2) ensurePattern
3) eval2nonVar

Are there still supporters of other names which were in discussion?


curry mailing list
Received on Fr Nov 12 2004 - 12:01:44 CET

This archive was generated by hypermail 2.3.0 : Sa Dez 09 2023 - 07:15:07 CET