Re: Evaluation Annotations (Was Re: Proposal: Relaxing restrictions in Curry

From: Herbert Kuchen <>
Date: Wed, 10 Nov 2004 11:27:34 +0100

I agree with the suggested changes w.r.t. "rigid", and I also agree with
Bernd that a new name might better reflect the semantics.

Bernd Brassel wrote:
> "rigid" is in my opinion understandable only in the contrast to
> "flexible". As there is no dual function to the new primitive, I would
> like to see it called differently. Here are a few suggestions:
> 1) waitOn - nicely expresses the identity on its argument but might
> be too operational (on the other hand, we would like to influence only
> operational behaviour with it)
> 2) suspendOn - similiar
> 3) groundVal - returns the ground value of its argument, (not a
> predicate as it is not called isGrundVal). Might sound like it should
> compute what ground does in Wolfgangs former mail:
>> function ground :: a -> a, which (again lazily) ensures that its
>> result is a ground term

I prefer "wait" (waitFor?) or "ground".


curry mailing list
Received on Mi Nov 10 2004 - 13:43:02 CET

This archive was generated by hypermail 2.3.0 : Di Nov 28 2023 - 07:15:08 CET